No spark at the ignition coil

Bouncin' Betty

New Member
Jul 9, 2024
North Carolina, USA
Hi, I've had this Jeep for about a year. Slowly been learning its quirks, fixing issues here and there, and doing some upgrades. It's a '91 with a 4.0 motor from a '94 Cherokee. 5 spd manual.

This past week, I got around to swapping the entire steering column with a pre-owned unit. The reason I replaced the whole column is because of broken ignition, you had to start it by pulling on the rod inside the column manually, and activate a secondary push button on the dash to bypass the key. The old one was ripped apart as long as I've owned this rig. So, the new unit I found has tilt function which is nice. And it's in one piece and starts with a key. Swapping the steering column out was a bit of a chore. I had to yank the old shaft out, and work in the new one with all my might.

When I finished installing the new unit and snugged all the connections onto the new column, I hooked up the battery. There was some clicking noises that came from the dash area which concerned me. I went and turned the key on and noticed my check engine light didn't come on which also concerned me. I then changed the light bulb for the check engine light. The next time I cycled the key, the check engine light started working again.... I'm not sure if the connection needed adjustment, or if there is a potential PCM issue. Every time I cycle the key now, I do get the CEL.

So I went to start it and it just cranks and will not start. I have fuel pressure at the rail, just no spark at the ignition coil. The coil checks good and I even tried another known good coil. Checked the fuses under the hood, they are intact, fuses in the cab are also not blown.

Checked the codes, all I get is 12, 33, 55

12*: Battery or computer recently disconnected within the last 50 start cycles). This is a very common code. Will not trigger a "Check engine light".
33*: Air conditioning clutch relay circuit open or shorted. If your Jeep doesn't have AC you will always get this code. Will not trigger a "Check engine light".
55*: PCM has finished telling you the codes. This means you are done reading codes.

Is there anything else I can check? Have I created an issue by replacing the steering column?
I found a flow chart to follow for a no spark no start condition, so I'm going to follow that and update here. Last night I back probed my map sensor and got my 5 volt reference, going to check all sensors for potential issues. Maybe something is shorted out. I'm going out of town for a week so won't be working on Betty for a little while.
I did some diagnostics today, starting with the crankshaft position sensor. I tested the voltage at the harness and it's 5 volts. The voltage pulses when I crank the engine.

Then I tested the camshaft position sensor (or distributor pickup). Back probing the sensor output wire, got 5 volts once my rotor was in the right position. When cranking, the voltage does pulse like it should. The ground wire is good, and the voltage supply wire is sending voltage. The previous owner mentioned the battery quick disconnect he installed messed up his pickup coil one time. Doesn't seem to be the case this time. 🤷‍♂️

Last thing before I ran out of time, checked the ignition coil at its wire harness. Back probing the harness at the coil, got no voltage. Disconnected the harness and stuck the probe in the socket. No voltage. There is supposed to be 12V constant.

So, next time I'm going to start by tracing that wire.
I finally solved the no spark issue today... It's so fun working on old cars, especially ones that have changed owners a few times and worked on and maintained by people who love to tinker and "make it work." I hoped it would be something common, or obvious, that other Jeep owners would have been through already. Maybe it would help someone in the future. I guess it is obvious now that I've learned about another "quirk" my Jeep has. I traced the wire from the ignition coil down the wiring harness, all the way to the firewall. The wiring is frankly disturbing, but it's fine. I included pictures for your enjoyment. The 12V constant eventually connects to this little switch beside the driver's seat.

Long story short, I always wondered what this switch does. It is a kill switch for the ignition coil.

There's a few things I think could have happened. The old column may have bypassed this kill switch, since it had no key to start it. Or, I bumped it by accident when wrestling the steering column (I stood on the driver's seat and yanked it out), or it flipped itself when I heard something clicking at the beginning of this ordeal. There was nothing wrong with it the whole time, just had to flip this switch. It runs really good!

12V constant.jpg

12V constant 2.jpg

12V constant 3.jpg

12V constant 4.jpg

12V constant 5.jpg
12V constant 6.jpg

Fully functional steering column.jpg
Nice that you figured it out and in the end it was a simple fix. I wired a kill switch into mine but it's a lot more hidden than that one. I would be concerned about what you just did, bumping it by accident lol. I would have to relocate that so it's not so easy to find and out of the way. Only good thing, like you mentioned, about problems like this is it makes you hunt stuff down and figure out what previous owners did. I too discovered the remnants of a previous kill switch in mine that was no longer wired but still there. I removed it and fixed the cut wires.