95 YJ Problems

ML's 95 YJ

New Member
Joined
Jan 22, 2023
Messages
2
Location
Mobile, AL
Hello all,

I bought a 95 YJ a few months ago and now I'm a beginner mechanic. I had the jeep running but it wouldn't always start on the first turn of the key. I usually turn the key off and then back on again then I would (hopefully) hear a click, click, click errrrrrm sound and the jeep would start. I checked the starter and the solenoid. They both checked out. I replaced the ignition lock cylinder but not the ignition switch actuator. Then I decided I needed a new ignition starter switch. I got the old one off and the new one on but now it doesn't crank. The dash lights work and the headlights are working... But, when I turn the key to start it, I get nothing... nothing not even a click.

What did I do wrong?
 

joshua92mopar

New Member
Joined
Jan 22, 2023
Messages
2
Location
Baytown Texas
Hello all,

I bought a 95 YJ a few months ago and now I'm a beginner mechanic. I had the jeep running but it wouldn't always start on the first turn of the key. I usually turn the key off and then back on again then I would (hopefully) hear a click, click, click errrrrrm sound and the jeep would start. I checked the starter and the solenoid. They both checked out. I replaced the ignition lock cylinder but not the ignition switch actuator. Then I decided I needed a new ignition starter switch. I got the old one off and the new one on but now it doesn't crank. The dash lights work and the headlights are working... But, when I turn the key to start it, I get nothing... nothing not even a click.

What did I do wrong?
I currently have the ignition switch out of my 95 Rio grande. Changed the ignition tumbler and my steering column is all jacked up. So I'm currently installing a push button start ebay racing ignition switch.at least until I find an old GMC Jimmy with tilt steering column Sounds to me like you took the right procedures . Maybe check body or engine block ground?
 
OP
ML's 95 YJ

ML's 95 YJ

New Member
Joined
Jan 22, 2023
Messages
2
Location
Mobile, AL
Thank you for responding. I've got her running again! I think the actuator rod access hole and the key ignition weren't lined up correctly. The key feels a lot better when I turn it... It was definitely loose. I'm going to have to work on the two electrical connectors as I believe I have a short there or bad contact. Thank you again! ml

What is your jeep doing?
 
  • Like
Reactions: Stoopid Jeep