What is this?


Frankenho

New Member
Joined
Dec 11, 2020
Messages
4
Location
Springfield mo
Jeep won't start with indications of a bad ecm. Got a new one, no help. Wondering if I need to do something with this little guy

20210111_160418.jpg
 

machoheadgames

Certified YJ Researcher
Supporting Member
Joined
May 19, 2020
Messages
227
Location
Dallas, TX
That's an air conditioning plug for 2.5L only YJs, of course equipped for AC.

What are the issues? What year, engine, transmission? What has been done to troubleshoot?
 

machoheadgames

Certified YJ Researcher
Supporting Member
Joined
May 19, 2020
Messages
227
Location
Dallas, TX
93 2.5 4 cyl, 5 speed (no a/c). Cranks fine, won't start. No check engine light. Changed ecu, no help.
Hmm that does sound PCM related. If you turn the key to battery mode and wait a few minutes, does the CEL ever come on and fire the fuel pump? Wondering if the replacement PCM is bad also.
 

machoheadgames

Certified YJ Researcher
Supporting Member
Joined
May 19, 2020
Messages
227
Location
Dallas, TX
Code reader plug? I didn't think they had those.
Maybe a bad crankshaft position sensor
It’s zip tied to the loom that goes to the PCM. Upper driver’s side of firewall area. Close to the brake booster. Have to use older style tools to plug into it.

Sadly, a bad crank sensor won’t cause the check engine light to malfunction.
 

Flyer58

YJ Enthusiast
Joined
Apr 12, 2020
Messages
315
Location
Magnolia, Texas
Check the CEL bulb circuit and the bulb itself. Good question earlier if it ever comes on.

I found a good electrical contract cleaner like DeoxIT solves many problems.