VSS and 4WD light issues


New Member
Jan 2, 2023
Lake Ozark, MO
Hey all! New member and first post! I have a 1990 YJ that I just finished a 4.0L and AW4 swap in. Everything is up and running and I just have two issue oustanding.

First the VSS on the AW4 and wiring harness was a three wire setup. I am using the vss for a 1991 YJ which is a two wire setup. I looked all over online and found info that said I could just use the wh/or signal wire and the blu/Lt blu wires to move from the three wire to the two wire setup. The speedometer works now so the sensor is turning but I am getting a code for no speed sensor detected……anyone know the right way to wire it?

Second, the 4wd indicator light won’t work. I have redone the wiring so that the switch on the transfer case connects the ground to turn on the light when the handle is pulled. I can connect the two wires at the switch and the light comes on. I replaced the switch (the old one was bad) and tested it and its good and will turn the light on if I connect the wires and push it in. But it wont work threaded into the housing? Any thoughts???? All help is appreciated!!!
You can definitely use a 2 wire VSS from the 91 in place of the 3 wire from 92-97. I forget the wire colors and how they need to be matched up but you can securely get it working.

If your Speedo is working, I’d think you’re good to go. Have you disconnected the battery to clear the code? It’s probably in the computer’s memory and just stored, not actively still logging. Disconnecting the battery will clear the code and then you can see if more driving brings it back or keeps it gone.

As for the 4x switch, that seems to totally depend on the switch you buy. I’ve seen many folks say parts store or omix or crown brand will not work because the button on them isn’t long enough and doesn’t reach the shift selector in the tcase. I used a Chrysler switch when I did mine, J8134473, and got it from Amazon. It says unavailable there though, so try to find it on eBay or something.

Dorman 600-551 seems to have good enough reviews to maybe be worth a try. Not sure which one you bought though.

I have a feeling you’ll be squared away on both issues soon enough. Good luck!
  • Like
Reactions: Chris
Thanks for help Macho! I had the three wire vss hooked up origionally when I first got it running and the code was not there. It didn’t show up until after the two wire was installed but I ran it with the two wire vss improperly adjusted and the speedo was not reading. I readjusted it and got the speedo working but haven’t cleared the codes. I will pull the battery cables and reset everything and try it again. If that doesn’t work maybe switch the wires.

I will definately try that chrysler switch. There isn’t alot of room for error with them thats for sure. Thanks again!!
  • Like
Reactions: machoheadgames