Help


Heatray40

New Member
Joined
Apr 7, 2021
Messages
2
Location
Ri
I have a 87 jeep wrangler 4.2 and I had the motor rebuilt had it for about 3 years now sits in my garage all winter .the problem I'm having is some time when yoh start it up it runs awesome and there's time I start it up and it runs like crap. And I replaced everything under the hood .can some one give me an idea of what is wrong thanks
 

jeepjoe43

YJ Enthusiast
Lifetime Supporting Member
Joined
Dec 4, 2020
Messages
371
Location
Black Canyon City, AZ 85324
I would start by checking the fuel pressure, pumps can be intermittent, though they usually just die.
Intermittent stuff is is a bitch.
After sitting, is it initially slow to start? That's an indication the pump is on it's way out, or at least a part of it.
It could be as simple as a filter, but i'm going to bet you've already done that.
 
OP
H

Heatray40

New Member
Joined
Apr 7, 2021
Messages
2
Location
Ri
I would start by checking the fuel pressure, pumps can be intermittent, though they usually just die.
Intermittent stuff is is a bitch.
After sitting, is it initially slow to start? That's an indication the pump is on it's way out, or at least a part of it.
It could be as simple as a filter, but i'm going to bet you've already done that.
I would start by checking the fuel pressure, pumps can be intermittent, though they usually just die.
Intermittent stuff is is a bitch.
After sitting, is it initially slow to start? That's an indication the pump is on it's way out, or at least a part of it.
It could be as simple as a filter, but i'm going to bet you've already done that.
We just installed a fuel injection kit with all new lines .pump filter and still does it
 

jeepjoe43

YJ Enthusiast
Lifetime Supporting Member
Joined
Dec 4, 2020
Messages
371
Location
Black Canyon City, AZ 85324
Hmm...I guessing no codes either?
Maybe time to inspect all the connectors on the engine harness.
Had a similar Gremlin, turned out to be a stressed/broken supply wire to the 2 pin coil plug.
 

Gilaguy23

Member
Joined
Apr 12, 2021
Messages
47
Location
Arizona
Idles poorly or just cuts out and sputters and the like at all engine rpms? Loss of a cylinder or 2 or ?? Rough idle and stalling could be a hung up open EGR valve.
 

jeepjoe43

YJ Enthusiast
Lifetime Supporting Member
Joined
Dec 4, 2020
Messages
371
Location
Black Canyon City, AZ 85324
If you are suspecting cylinders then maybe a compression test is in order.
I still suspect electrical from my own experiences.
Been a long time mechanic, but I confess I'm not a YJ expert and I can only give you my experiences.
Look for simple solutions first.