Head gasket/ piston rings replacement 89 2.5l

jpjeep26uk

Member
Joined
Nov 12, 2022
Messages
37
Location
UK
Hi all, I have searched just in case this has already been covered and nothing stands out.
So...I've pretty much exhausted my options for curing a new backfire and it appears to be a knackered number
2 piston ring or the piston itself. Not a happy bloke.
Has anyone done this themselves and do you have any advice on how to replace rings or a piston? Or if anyone here is UK based then maybe the name of a reputable garage in the Midlannarrow anything downds? Is there a list of things I'll need to buy before I start etc. Thanks everyone .
(Picture shows the cloudy exhaust output immediately after ignition) Drove past my girlfriend in her car and she could smell petrol from inside her car- not sure if that helps narrow anything down haha)

Screenshot_20221123-070640_Gallery.jpg
 
Last edited:

Flyer58

YJ Enthusiast
Joined
Apr 12, 2020
Messages
674
Location
Magnolia, Texas
Before digging in too deep do a compression test. I suspect the #2 cylinder is weak.

Also, with the key OFF !!, Rotate the crankshaft using a socket and long ratchet or breaker bar so you can feel and hear the compression. If it sounds like air is escaping easily through the intake or exhaust you may have a bad valve or carbon is not letting the valve fully seat.
 
OP
jpjeep26uk

jpjeep26uk

Member
Joined
Nov 12, 2022
Messages
37
Location
UK
Before digging in too deep do a compression test. I suspect the #2 cylinder is weak.

Also, with the key OFF !!, Rotate the crankshaft using a socket and long ratchet or breaker bar so you can feel and hear the compression. If it sounds like air is escaping easily through the intake or exhaust you may have a bad valve or carbon is not letting the valve fully seat.
OK, I'll start with a compression test. Do you know where the fuse is that shuts the fuel pump off, or do you mean I should do the version above? Or even do both? I'm partially deaf so will I hear the air escaping or can I feel it if I stick my finger in the spark plug hole? (I read that somewhere)
 

Flyer58

YJ Enthusiast
Joined
Apr 12, 2020
Messages
674
Location
Magnolia, Texas
Yes two steps. The compression test should have the fuel pump off by pulling the fuse, not sure where that is, Disconnect all sparkplug wires and hold the throttle wide open then turn the engine over using the starter. You can try it with both a warm engine and cold but I bet a low compression will show up on both tests.

The second test of turning it by hand is not really necessary but may indicate if the leak is in the head or piston and you should notice a different feel in one cylinder compression even though you may not hear the difference.

Backfiring is usually caused by bad spark timing, valve problems, or poor mixture control. Since you have a throttle body injection it would lead me to think all plugs would be close to the same. You have one black plug so for whatever reason that cylinder has a lot of unburned fuel in it. Could be poor spark but you said you were going to change the cap, wires, and plugs. Poor compression also causes a rich condition because the fuel doesn't completely burn as it should.

You can try the Sea Foam trick of slowly pouring or spraying a can of Sea Foam into the throttle body as the engine is running, turn off the engine and let it sit for 10 minutes or so and then start it. Look for a youtube video about that. Lot's of smoke but it does clean the induction, valves, and pistons. You may just have a chunk of crud preventing the valve from seating.

I still find it strange that this started by replacing a belt. I'm not familiar with that year YJ so I can't say it's not something else.
 
OP
jpjeep26uk

jpjeep26uk

Member
Joined
Nov 12, 2022
Messages
37
Location
UK
Flyer that's really helpful guidance. I'll do this on Saturday and see how far I get. I'm beginning to think it's pure coincidence that it showed up the same day as a belt change. It just seemed really odd after 2000 spotless miles around the UK in 3 months - one bit of which was done at a steady 56,mph non-stop for 5 hours- not a peep.
Work so far this week to find the culprit-
  1. Pulled the ignition pack off and apart from 30 years of dust it came up clean after a good brass brush with contact cleaner (new one coming this weekend),
  2. Replaced the spark pugs and to torque amount,
  3. Pulled the dist cap and it did have some kind of light oily deposit in it so I cleaned that too and the rotor (New ones coming Saturday)
  4. Took off the PCV valves and soaked them in Carb Cleaner and cleaned the metal one with a gentle brass brush (new front metal one coming on Saturday - I can't locate a rear plastic cylinder one for love nor money!)
  5. Replaced the fuel filter as well.
After all that work as well as cleaning up the TBI again, the pic above is the result along with backfiring and a terrible idle so I'll fit all the new bits and then follow what you say above to see what's up. Again - thanks for the guidance.
 
  • Like
Reactions: Flyer58
OP
jpjeep26uk

jpjeep26uk

Member
Joined
Nov 12, 2022
Messages
37
Location
UK
Yes two steps. The compression test should have the fuel pump off by pulling the fuse, not sure where that is, Disconnect all sparkplug wires and hold the throttle wide open then turn the engine over using the starter. You can try it with both a warm engine and cold but I bet a low compression will show up on both tests.

The second test of turning it by hand is not really necessary but may indicate if the leak is in the head or piston and you should notice a different feel in one cylinder compression even though you may not hear the difference.

Backfiring is usually caused by bad spark timing, valve problems, or poor mixture control. Since you have a throttle body injection it would lead me to think all plugs would be close to the same. You have one black plug so for whatever reason that cylinder has a lot of unburned fuel in it. Could be poor spark but you said you were going to change the cap, wires, and plugs. Poor compression also causes a rich condition because the fuel doesn't completely burn as it should.

You can try the Sea Foam trick of slowly pouring or spraying a can of Sea Foam into the throttle body as the engine is running, turn off the engine and let it sit for 10 minutes or so and then start it. Look for a youtube video about that. Lot's of smoke but it does clean the induction, valves, and pistons. You may just have a chunk of crud preventing the valve from seating.

I still find it strange that this started by replacing a belt. I'm not familiar with that year YJ so I can't say it's not something else.
Hi Flyer, I did a comp test and all four came up around the 130/ 135 mark,give or take a few %. I think that's OK according to the manual? I haven't received the seafoam yet so I guess that's the next step on my adventure? Thanks a lot
 
OP
jpjeep26uk

jpjeep26uk

Member
Joined
Nov 12, 2022
Messages
37
Location
UK
Hi Flyer, I did a comp test and all four came up around the 130/ 135 mark,give or take a few %. I think that's OK according to the manual? I haven't received the seafoam yet so I guess that's the next step on my adventure? Thanks a lot
OK, I took the valve cover off and my gosh, it was absolutely clotted with filth, literally gunked up with oil and slimy crud and grit.
I literally chiselled off a kind of scaly deposit. Took me 90 mins to get it clean.

The two holes for the valves were filled with years old goo. I shined it up,put new sealant on and refitted it.
I installed a brand new coil ignition and thrashed it down the local highway at 65 to 70 for 15 miles.
Not a peep, No flapping, no coughing , no stally crap, no misfires. Really felt a bit quicker and smoother. So for now at least, I think I may have fixed it and will see how long it lasts. Could it be a cruddied up valve cover could cause serious misfiring?

20221126_125422.jpg


20221126_125439.jpg